Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 07:00 CEST
Scheduled
Dear Customer,
Gibfibre will be performing a scheduled maintenance which will be affecting your Internet and Tv services. There will be a possibility of micro-cuts during the maintenance window.
Normal service will be restored upon completion of works.
We apologise for any inconvenience caused.
Please do not reply directly to this mail as it is sent from an unattended mailbox.
Kind regards,
Gibfibre Team.
Posted Jun 23, 2025 - 12:38 CEST
This scheduled maintenance affected: Business Services (Internet, Voice, TV) and Residential Services (Internet, Smart DNS, Voice, TV).