Services Outage: Elliots Battery, Europa Walks, City Center

Incident Report for GIBFIBRE

Resolved

The repair work has been completed, and normal service has been restored.
Posted Jun 02, 2026 - 23:32 CEST

Identified

The damaged optical fibre has already been identified, and our technicians are currently carrying out repairs.
Posted Jun 02, 2026 - 22:32 CEST

Investigating

Our technicians are already dispatched for the issue.
Posted Jun 02, 2026 - 20:59 CEST
This incident affected: Business Services (Internet, Voice, TV) and Residential Services (Internet, Voice, TV).