Services Outage
Incident Report for
GIBFIBRE
Identified
The issue has been identified and a fix is being implemented.
Posted
Apr
20
,
2026
-
16:10
CEST
Investigating
We are currently investigating a loss of service in several areas. The affected areas are:
Lynch’s Lane
Crutchetts Ramp
Irish Town
Turnbull Lane
Line Wall
ICC Building
Main Street
Casemates Square
Our external plant teams are already on site and will endeavour to repair the issue as soon as possible.
We appreciate your patience and apologise for any inconvenience this may cause.
Posted
Apr
20
,
2026
-
14:58
CEST
This incident affects: Business Services (Internet, Voice, SIP Trunk, TV) and Residential Services (Internet, Voice, TV).
×
Subscribe to Incident
Subscribe to updates for
Services Outage
via . You'll receive .