Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2025 - 10:00 CEST
Scheduled
Gibfibre will be conducting essential maintenance in your area to enhance and address minor faults in the fibre provision. Please be advised that there will be brief interruptions, or micro cuts, during the maintenance window. We sincerely apologize for any inconvenience this may cause. Rest assured, normal services will resume promptly following the maintenance period.
Posted Jun 06, 2025 - 09:50 CEST
This scheduled maintenance affected: Business Services (Internet, Voice, TV) and Residential Services (Internet, Smart DNS, Voice, TV).