We will be undergoing scheduled maintenance during this time.
Posted Feb 13, 2026 - 10:38 CET
Scheduled
Dear customers,
Gibfibre will be performing a scheduled maintenance. These works are to improve the provision of our services. Normal service will be restored upon completion of works.
Thank you for understanding.
Posted Feb 13, 2026 - 10:37 CET
This scheduled maintenance affects: Business Services (Internet, Voice, TV) and Residential Services (Internet, Voice, TV).