Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2026 - 06:00 CET
Scheduled
Dear customers,
GibFibre will be performing emergency maintenance to improve the provision of our services. During this time, some service disruption may occur in the affected areas. We apologise for any inconvenience and appreciate your understanding.
Regards,
Posted Feb 17, 2026 - 19:47 CET
This scheduled maintenance affected: Business Services (Internet, Voice, SIP Trunk, TV) and Residential Services (Internet, Voice, TV).