Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 12:27 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 08:10 CET
Scheduled
There is a scheduled maintenance in order to improve the feed cables in Glacis Estate for all your services. There will be service disruption in this area throughout the course of the day. We apologise for the inconvenience and will ensure service is restored fully as soon as possible.