Internet Outage

Incident Report for GIBFIBRE

Resolved

Connectivity and services have now been restored in all affected areas.
Posted Mar 05, 2026 - 20:04 CET

Monitoring

Out technicians already located the incident and partially fixed the fibre installation.
Only remaining Castle Road and part of Main Street.
Posted Mar 05, 2026 - 19:54 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2026 - 16:52 CET

Investigating

Dear Customer,

We are currently experiencing a service outage. Our technicians are working to resolve the issue as quickly as possible.

The following areas are currently affected:

Ramilles House

Warspite House

Malaya House

Gardiners Road

Main Street

Europa Road

Hargraves Ramp

Trafalgar House

Kings Yard Lane

St Jagos Estate

Moorish Castle

Alameda Estate

Gardiners View

Rock Gardens

Capilano House

St Mary School

Castle Road

We apologise for the inconvenience and appreciate your patience while we work to restore the service.
Posted Mar 05, 2026 - 15:55 CET
This incident affected: Business Services (Internet, Voice, TV) and Residential Services (Internet, Voice, TV).