Scheduled Maintenance: 26031001 - Internet and TV

Scheduled for Mar 10, 01:00 - 06:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 10:22 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 10:21 CET

Scheduled

Dear customers,

GibFibre will be performing maintenance to enhance the quality of our services. During this time, some service disruptions may occur in the affected areas. Please do not turn off your router during this maintenance window. We apologise for any inconvenience and appreciate your understanding.

Kind Regards.
Posted Mar 09, 2026 - 10:20 CET
This scheduled maintenance affects: Business Services (Internet, Voice, TV) and Residential Services (Internet, Voice, TV).