Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2025 - 07:30 CEST
Scheduled
Dear Customer,
Gibfibre will be performing a short maintenance to improve your CATV services. Interruptions to your services will be minimal but please be aware there could be several micro cuts during the maintenance window.
We apologise for any inconvenience caused.
Please do not reply directly to this mail as it is sent from an unattended mailbox.
Kind regards,
Gibfibre Team.
Posted Jul 01, 2025 - 14:03 CEST
This scheduled maintenance affected: Business Services (Internet, Voice, TV) and Residential Services (Internet, Smart DNS, Voice, TV).